dotfiles/common/systemModules/nix.nix
2025-02-18 18:29:54 -05:00

19 lines
297 B
Nix

{
config,
stable,
inputs,
...
}:
{
nix = {
settings = {
extra-platforms = config.boot.binfmt.emulatedSystems;
experimental-features = [
"nix-command"
"flakes"
];
};
package = stable.nix;
nixPath = [ "nixpkgs=${inputs.nixpkgs}" ];
};
}