mirror of
https://github.com/sadan4/dotfiles.git
synced 2024-11-16 23:04:39 -05:00
25 lines
477 B
Nix
25 lines
477 B
Nix
{ NAME }: { config, inputs, ... }: {
|
|
imports = [
|
|
inputs.sops-nix.nixosModules.sops
|
|
];
|
|
sops = {
|
|
defaultSopsFile = ../../secrets.yaml;
|
|
defaultSopsFormat = "yaml";
|
|
age = {
|
|
keyFile = "/home/${NAME}/.config/sops/age/keys.txt";
|
|
};
|
|
secrets = {
|
|
password = {
|
|
neededForUsers = true;
|
|
};
|
|
};
|
|
};
|
|
users = {
|
|
users = {
|
|
"${NAME}" = {
|
|
hashedPasswordFile = config.sops.secrets.password.path;
|
|
};
|
|
};
|
|
};
|
|
}
|