mirror of
https://github.com/sadan4/dotfiles.git
synced 2024-11-16 23:04:39 -05:00
24 lines
407 B
Nix
24 lines
407 B
Nix
{ NAME }: { pkgs, ... }: {
|
|
virtualisation = {
|
|
libvirtd = {
|
|
enable = true;
|
|
qemu = {
|
|
ovmf = {
|
|
enable = true;
|
|
packages = with pkgs; [
|
|
OVMF.fd
|
|
pkgsCross.aarch64-multiplatform.OVMF.fd
|
|
];
|
|
};
|
|
};
|
|
};
|
|
};
|
|
users = {
|
|
users = {
|
|
"${NAME}" = {
|
|
extraGroups = [ "kvm" "libvirtd" ];
|
|
};
|
|
};
|
|
};
|
|
}
|