dotfiles/common/users/homeModules/dev/cpp.nix
2025-01-14 18:43:10 -05:00

30 lines
568 B
Nix

{ pkgs, unstable, ... }:
{
home = {
packages = with pkgs; [
meson
autoPatchelfHook
cmake
# clang
libgcc
glib
bear
glibc
pinned.gdb
lldb_19
cpkg.ceserver
unstable.llvmPackages_19.clang-tools
];
file = {
eslint_d_config = {
source = ../../../../dotfiles/eslintrc.json;
target = "./.config/.eslintrc.json";
};
gdb_config = {
source = ../../../../dotfiles/gdb;
target = "./.config/gdb";
recursive = true;
};
};
};
}