dotfiles/common/users/homeModules/sops.nix
2024-11-26 17:01:58 -05:00

15 lines
392 B
Nix

{ config, inputs, ... }:
{
imports = [
inputs.sops-nix.homeManagerModules.sops
];
sops = {
age.keyFile = "/home/${config.home.username}/.config/sops/age/keys.txt";
defaultSopsFile = ../../../secrets.yaml;
secrets.hosts = {
format = "binary";
sopsFile = ../../../secrets/hosts;
path = "/home/${config.home.username}/.config/gh/hosts.yml";
};
};
}