mirror of
https://github.com/sadan4/dotfiles.git
synced 2024-11-16 23:04:39 -05:00
16 lines
392 B
Nix
16 lines
392 B
Nix
{ config, inputs, ... }:
|
|
{
|
|
imports = [
|
|
inputs.sops-nix.homeManagerModules.sops
|
|
];
|
|
sops = {
|
|
age.keyFile = "/home/${config.home.username}/.config/sops/age/keys.txt";
|
|
defaultSopsFile = ../../../secrets.yaml;
|
|
secrets.hosts = {
|
|
format = "binary";
|
|
sopsFile = ../../../secrets/hosts;
|
|
path = "/home/${config.home.username}/.config/gh/hosts.yml";
|
|
};
|
|
};
|
|
}
|